Willkommen in Spybot - Search & Destroy

SpyBot - Search & Destroy
Freeware, ©'2000-2002 Patrick Michael Kolla

SpyBot - Search & Destroy durchsucht ihren Rechner nach verschiedenen Arten von Bedrohungen aus dem Internet - dazu gehören Spy- und Adware, Keylogger und Gebrauchsspuren zum Beispiel die Liste der zuletzt besuchten Internetseiten). Spybot-S&D kann außerdem einige Systemprobleme beheben.

Spybot-S&D bietet des weiteren einige Werzeuge, wie z.B. den Aktenvernichter.

Lizenz
Warum Freeware? Darauf gibt es eine einfache Antwort. Was bekommt man, wenn man Software kauft? Bloß eine Menge Nullen und Einsen. Höchstens als Kunst würde ich für so was noch zahlen..
Aber wenn das Hauptziel ihrer Anordnung ist Geld zu verdienen - durch einen Festpreis oder Werbebanner - dann gefällt mir das ganz und gar nicht!
Und darum ist dieses Programm kostenlos. Aber wenn Sie es mögen und es Ihnen hilft, bitte ich um eines: sprechen Sie ein Gebet zu Ihrem Gott - oder woran auch immer Sie glauben - für mich und wünschen mir ein wenig Glück

Benötigte Soft- und Hardware
Ein 32bit Windows wird benötigt, wie z.B. Windows 95, 98, ME, NT, 2000 oder XP. Außerdem brauchen Sie etwa 2 Megabyte freien Speicherplatz auf Ihrer Festplatte..

Gebrauch
Starten Sie das Programm, indem Sie die Datei SpybotSD.exe doppelklicken. Wenn Sie Spybot-S&D zum ersten Mal benutzen, werden Sie gefragt, ob Sie ein Desktopsymbol und/oder einen Eintrag im Startmenü erstellen wollen.

Danach sind Sie schon im Programm!

Wenn Sie mehr Hilfe benötigen, lesen Sie weiter unter Überprüfung.


Produkt-Informationen

In dieser Abteilung finden Sie mehr Informationen über die Probleme, die Spybot-S&D erkennt. Wenn Sie direkt von der Ergebnisliste hierher kommen, ist Ihr Problem evtl. schon ausgewählt, sonst können Sie das über die Pulldown-Liste nachholen.

Diese Informationen zeigen zwar URLs, aber da einige der dahinterliegenden Webseiten direkt einen (ActiveX) Download starten, können Sie nicht mit einem einfachen Klick geöffnet werden. Stattdessen können Sie sie im Kontextmenü auswählen, nachdem Sie sichergestellt haben, dass Ihr Browser keinen ActiveX-Inhalt ohne Nachfrage ausführt.

Sie können hier auch Produkte von zukünftigen Suchen aussuchen; dabei wird die gleiche Liste benutzt, die Sie auch unter Produkt-Ausnahmen finden).

Diese Abteilung ist erreichbar, indem Sie Produktinfo in der Abteilung Info & Lizenz auswählen.


Über Spyware

Was ist Spyware? In kurzen Worten, Spyware ist Software, die ohne besondere Nachfragen Informationen von Ihrem Computer an einen Platz im Internet überträgt, die Ihnen persönlich zugeordnet werden kann.

Spyware ist üblicherweise nicht die Software die man installiert selbst, sondern wird als Add-On mitinstalliert; manchmal lassen sich diese Add-Ons während der Installation deaktivieren, manchmal nicht. In den meisten Fällen steht irgendwo in den Benutzungbedingungen etwas davon, dass persönliche Daten übertragen werden, aber die meisten Benutzer lesen diese wohl nie bis zum Ende und wissen daher gar nicht, dass Spyware auf Ihrem System ist.

Eine weniger bedrohliche Sorte is Adware. Adware ist der Spyware ziemlich ähnlich, überträgt aber keine persönliche Informationen, oder verspricht zumindest diese nicht zu verkaufen oder weiterzugeben. Stattdessen werden alle Daten kombiniert und nicht mehr zuordnungsbar verkauft.

Adware ist oft ein Nebeneffekt von Spyware, weil beide dem gleichen Zweck folgen - Ihr Verhalten zu beobachten und auf Sie persönlich abgestimmte Werbung einzublenden.

Ein anderes Problem, das in der gleichen Kategorie erkannt wird, sind Tracking cookies. Cookies werden überall im Internet benutzt, um mehr oder weniger sinnvolle Informationen zu speichern. Werbefirmen setzen Cookies oft, wenn der Browser nur ein Banner von ihnen lädt. In diesem Fall (und wenn Ihnen in diesem Cookie eine persönliche ID zugewiesen wird) bekommt der Anbieter es immer mit, wenn Sie eine Seite besuchen, die seine Banner enthält.


Über System-Innereien

Die Registrierungsdatenbank von Windows enthält viele Informationen. Diese können mit guten kommerziellen Programmen wie Symantec™ System Works überprüft werden. Aber einige Kleinigkeiten finden diese nicht, und danach sucht Spybot-S&D:

  • Fehlende Hilfedateien – deren Pfad wird in der Registrierungsdatenbank gespeichert. Wenn dieser Eintrag auf ein ungültiges Verzeichnis zeigt, zeigt Spybot-S&D das an und erlaubt das Korrigieren.

  • Fehlende Gemeinschaftsbibliotheken – Die Registrierungsdatenbank enthält auch eine Liste der Gemeinschaftsbibliotheken (DLLs), wo sie abgelegt sind und von wie vielen Programmen sie genutzt werden. Spybot-S&D überprüft, ob diese Informationen korrekt sind, und erlaubt sie zu korrigieren.

  • Applikationspfade – Einige Anwendungen speichern Ihren Programmpfad in der Registrierungsdatenbank. Wenn diese Informationen veraltet sind, zeigt Spybot-S&D das an und erlaubt es zu korrigieren.

  • Falsche Deinstallationsinformationen – Jedes (gute) Programm hat seine einigen Deinstallationsroutinen und speichert Informationen darüber in der Registrierungsdatenbank. Wenn diese falsch sind, z.B. weil das Programm aus einem temporären Verzeichnis heraus installiert wurde, das es nicht mehr gibt, zeigt Spybot-S&D das an.

  • Ungültige Desktop-Verknüpfungen – wenn eine Verknüpfung auf Ihrem Desktop auf eine nicht mehr existierende Datei zeigt, zeigt Spybot-S&D das an und erlaubt Ihnen, die Verknüpfung entweder zu aktualisieren oder zu löschen.

Warnung: Bitte beachten Sie, dass Änderungen an diesen Einträgen ihr System unstabil machen können! Wenn Sie sich über die Natur des Problems nicht sicher sind, lassen Sie die Finger davon!
Besonders Microsoft Office™ hat einige Einträge in der Registrierungsdatenbank, die falsch sind. Ich habe diese problemlos korrigieren bzw. löschen können, aber nachträgliche Probleme können nicht ganz ausgeschlossen werden.


Über Gebrauchsspuren

Gebrauchsspuren sind sozusagen ihre unbeabsichtigten Fingerabdrücke in ihrem System. Immer wenn Sie eine Internetseite besuchen, oder einfach nur eine Datei öffnen, wird diese Information in Windows gespeichert. In den meisten Fällen ist das sinnvoll - wenn Sie die gleiche Datei wieder öffnen, können Sie sie aus einer Liste auswählen, statt den kompletten Namen neu einzutippen oder sich durch den Verzeichnisbaum zu hangeln.

Aber manchmal möchten Sie diese Aktivitäten vielleicht auch verstecken, weil Spyware und Angreifer aus dem Internet diese Informationen nutzen können, um schneller Ihre wichtigsten Daten zu finden. Spybot-Search&Destroy kann einige der wichtigsten und häufigsten Gebrauchsspuren finden und entfernen.


Grundlegende Einstellungen

Alle wichtigen Einstellungen sind in einer Baumansicht in dieser Abteilung zusammengefasst. Die folgende Beschreibung orientiert sich an den Haupteinträgen in diesem Baum.

Installation

Hier können Sie Desktopsymbol und/oder Startmenüeintrag erstellen bzw. entfernen.

Spybot-S&D Einstellungen

Diese Einstellungen sollten selbsterklärend sein

Automatisierung

Spybot-S&D kennt zwei Arten von Automatisierung - bei Systemstart und bei Programmstart. Hier können Sie einstellen, ob das Programm zusammen mit Windows starten soll, oder automatisch nach Updates suchen, oder mit der Überprüfung warten, bis ein eingestellter Zeitraum abgelaufen ist oder bestimmte Programme beendet wurden.

Logdatei-Einstellungen

Spybot-S&D kann Details der Überprüfung und Behebung in eine Textdatei schreiben. Hier können Sie einstellen, ob das getan werden soll, und ob Datum und Uhrzeit im Dateinamen benutzt werden sollen.

Look & Feel

Ein paar Einstellungen zum Aussehen von Spybot-S&D können hier getroffen werden. Spielen Sie einfach mal damit rum.

Fehlerbericht

Wenn Sie sich über Probleme unsicher sind, können Sie einen Fehlerbericht an PepiMK Software schicken. Hier können Sie einstellen, wie dieser auszusehen hat. Sie sollten zumindest einstellen, dass System-Informationen und Ergebnisse mit übertragen werden (Sie können Sich diese später vor dem Senden noch einmal ansehen). Wenn Sie selber auch eine Kopie des Berichts erhalten wollen, können Sie das hier ebenfalls einstellen (dazu müssen Sie Ihren SMTP-Server einstellen - siehe auch Fehlerbericht-Hilfep).

Diese Abteilung ist erreichbar, indem Sie Einstellungen in der Abteilung Einstellungen auswählen.


Die Sprache der Bedienoberfläche einstellen

Spybot-S&D benutzt externe Dateien für alle Spracheinstellungen, so dass jeder der möchte eine Datei für seine Sprache erstellen kann. Bitte kontaktieren Sie PepiMK Software, wenn Sie dies wollen- dafür gibt es kein Geld, aber Sie ewigen Ruhm ;)

Standardmäßig werden alle Sprachen in der Liste angezeigt. Wenn Sie davon welche entfernen (oder später wieder hinzufügen) wollen, benutzen Sie bitte das Kontextmenü der Liste.

Diese Abteilung ist erreichbar, indem Sie Sprache in der Abteilung Einstellungen auswählen.


Datensätze - Was soll gesucht werden?

Spybot-S&D arbeitet mit Datensätzen, um flexibler zu sein. Jeder Datensatz ist eine Datei, die Probleme beschreibt, die von Spybot-S&D gefunden und behoben werden können.

Diese Datensätze sind in Kategorien eingeteilt, damit Sie genau bestimmen können, nach was Ihr System überprüft wird.

Die Hauptkategorien sind Spy- und Adware, System-Probleme und Gebrauchsspuren. Für jede Kategorie sehen Sie Datensätze mit einer kurzen Überprüfung und der Anzahl der Dateien und Registrierungsdatenbankeintröge, die überprüft werden.

Sie können diese für die nächste Überprüfung aussuchen, indem Sie die Checkbox daneben auswählen.

Wenn Sie einen kursiv dargestellten Datensatz sehen, stammt dieser nicht von PepiMK Software (oder wird nicht offiziell unterstützt). Weil das Format der Datensätze öffentlich ist, kann jeder Datensätze schreiben. Da falsche oder schlechte Datensätze das System jedoch stark beschädigen können, kann PepiMK Software keine Garantie für diese Datensätze geben, und fragt Sie gegebenenfalls nach, ob Sie diesen Datensatz wirklich verwenden wollen.

Diese Abteilung ist erreichbar, indem Sie Datensätze in der Abteilung Einstellungen auswählen.


Ausnahmen - Was soll nicht gesucht werden?

Es gibt momentan vier verschiedene Ausnahmen:

Produkt-Ausnahmen

Diese Abteilung listet alle internen und externen Produkte auf. Wenn Sie ein komplettes Produkt von der Suche ausnehmen möchten (oder doch wieder danach suchen möchten), verändern Sie hier die Checkbox vor diesem Produkt.

Cookie-Ausnahmen

Cookies sind Gebrauchsspuren, aber evtl. möchten Sie einige sinnvolle Cookies behalten. Diese Abteilung zeigt alle momentan gesetzten Cookies und erlaubt, diese von zukünftigen Suchen auszuschließen.
(Das gilt momentan nur für Internet Explorer und Netscape Navigator - Cookies von Opera können nur komplett gelöscht werden)

Dateiende-Ausnahmen

Dabei geht es um den Standard-Datei-Öffnen-Dialog von Windows. Dieser speichert Listen der geöffneten und gespeicherten Dateien, nach Dateiendungen sortiert. Wenn Sie beispielsweise können Verweise auf WinWord-Dateien entfernen wollen, könnten Sie hier .doc markieren.

Einzel-Ausnahmen

Manchmal wollen Sie nicht ein ganzes Produkt von der Suche ausschließen, sondern nur eine einzelne Datei oder eine Eintrag in der Registrierungsdatenbank. Dies können Sie von der Ergebnisliste aus tun, dann werden diese Einzelprobleme hier gelistet, wo Sie sie auch wieder reaktivieren können.

Alle diese Listen haben Kontextmenüs mit erweiterten Funktionen zur Auswahl.

Diese Abteilung ist erreichbar, indem Sie etwas in der Abteilung Ausnahmen auswählen.


Einstellen der Download-Verzeichnisse

Einige Überprüfungen suchen nach Installationsdateien von Problemen, die von Spybot-S&D erkannt werden. Installationsprogramme, die explizit heruntergeladen werden müssen, werden nur in den hier eingestellten Verzeichnissen gesucht.

Sie können Verzeichnisse entweder aus einem Explorer-Fenster hier herein ziehen oder das Kontextmenü der Liste benutzen, um sie hinzuzufügen oder zu entfernen.

Diese Abteilung ist erreichbar, indem Sie Download-Verzeichnisse in der Abteilung Einstellungen auswählen.


Ein Skin aussuchen

Ein Skin (Oberfläche) aussuchen

Spybot-Search&Destroy unterstützt Skins, um die Programmfarben den Benutzervorlieben anzupassen.

Die Abteilung Skins zeigt die verfügbaren Skins an. Wenn Sie eines auswählen, wird es in einer einfachen Voransicht angezeigt, zusammen mit ein paar weiteren Informationen.

Wenn Ihnen das Skin gefällt, können Sie es übernehmen.

Diese Abteilung ist erreichbar, indem Sie Skins in der Abteilung Einstellungen auswählen.


Überprüfen des Systems

Nachdem Sie Spybot-Search&Destroy gestartet haben, können Sie sofort mit der Überprüfung anfangen.

Sofort nach Programmstart sehen sie den Überprüfungsschirm schon. Wenn nicht, wählen Sie bitte Search & Destroy in der Abteilung Spybot-S&D in der Werkzeugliste links im Schirm.

Der Suchbildschirm enthält eine Werkzeuge mit den wichtigsten Werkzeugen (diese können Sie zwischen oben und unter verschieben, wenn Sie wollen). Starten Sie die Überprüfung, in dem Sie den Knopf Überprüfen drücken.

Sie sehen nun den Fortschritt in der Statusleiste unten im Fenster (ganz unten rechts sehen Sie die Zeit, die der Vorgang vermutlich noch dauern wird), and können die Überprüfung mit dem Knopf Stop (der nur während der Überprüfung zu sehen ist) abbrechen.

Wenn die Überprüfung etwas gefunden hat, wird die Liste es anzeigen. Es gibt drei grobe Kategorien von Ergebnissen:

  • Rote Einträge bedeuten Spyware-Probleme, die aus Sicherheitsgründen behoben werden sollten. Diese Art von Problemen ist von vorneherein schon gewählt..

  • Schwarze Einträge sind Systeminnereien. Wenn Sie nicht genau wissen warum es dabei geht, lassen Sie entweder die Finger davon oder besuchen Sie das Support-Forum.

  • Grüne Einträge bedeuten Gebrauchsspuren. . Diese zu entfernen bedeutet in aller Regel keinerlei Probleme.

Für die meisten Probleme sind genauere Beschreibungen vorhanden. Wenn Sie ein Problem in der Liste auswählen werden Sie merken, dass der Knopf Beschreibung dieses Produktes verfügbar wird. Drücken Sie ihn, um nachzulesen, um was für eine Art von Problem es sich handelt.

Sie können nun die Probleme auswählen, die Sie beheben wollen; markieren Sie dazu die Checkboxen davor. Sie können alternativ auch den Knopf Alle Probleme markieren verwenden oder auf erweiterte Auswahlfunktionen im Kontextmenü der Liste zugreifen. Das Kontextmenü erlaubt Ihnen weiterhin, ganze Produkte oder auch nur einzelne Probleme von zukünftigen Suchen auszuschließen (sie können das später noch in der Abteilung Ausnahmen ändern).

Sobald Sie ausgewählt haben was Sie entfernen wollen, drücken Sie den Knopf Markierte Probleme beheben. Der Fortschritt wird wieder unten in der Statuszeile angezeigt.

Wenn Probleme nicht sofort behoben werden können (z.B. weil Dateien noch im Speicher geladen sind), bietet Spybot-S&D an, beim nächsten Systemstart mitzustarten, damit Sie die Probleme noch einmal überprüfen und endgültig entfernen können.

Wenn Sie zu einem späteren Zeitpunkt feststellen, dass Sie mehr entfernt haben, als Sie eigentlich wollten, können Sie dies in der Abteilung Wiederherstellen rückgängig machen.

Sie können die Überprüfungs-Einstellungen außerdem genauer einstellen, indem Sie Änderungen in den Abteilungen Datensätze und Einstellungen vornehmen.


Wiederherstellen

Diese Abteilung hat ebenso wie die zur Überprüfung eine verschiebbare Werkzeugleiste.

Wenn Sie in der Vergangenheit Spyware-Probleme behoben haben, werden Sie in dieser Liste angezeigt. Hier können Sie einzelne auswählen (siehe auch erweiterte Auswahlmöglichkeiten im Kontextmenü) und entweder rückgängig machen oder endgültig von Ihrem System entfernen.

Diese Abteilung ist erreichbar, indem Sie Wiederherstellen in der Abteilung Spybot-S&D auswählen.


Updaten

Um zu häufige größere Downloads zu vermeiden und mehr Flexibilität zu bieten, sind die meisten Überprüfungenroutinen in externen Datensätzen gespeichert.

Diese Datensätze, aber auch neue Hilfedatei, neue Sprachen, aktualisierte Produktbeschreibungen und mehr können über die integrierte Update-Funktion direkt heruntergeladen werden.

Dazu wird verständlicherweise eine geöffnete Internetverbindung benötigt.

Nun können Sie den Knopf Suche nach Updates drücken. Daraufhin wird eine Liste der verfügbaren Updates heruntergeladen und mit den Dateien auf Ihrem System verglichen.
Neue Dateien werden in der Liste angezeigt, wo Sie sie auswählen und sich mit dem Knopf Updates herunterladen besorgen können. Während des Downloads wird jede fertige Datei mit einem grünen Haken gekennzeichnet.

Wenn Sie sich zuerst über die Updates informieren möchten, benutzen Sie den Knopf Neuigkeiten lesen oder besuchen Sie das Support Forum.

Diese Abteilung ist erreichbar, indem Sie Update in der Abteilung Online auswählen.


Einen Fehler melden

Sie sollten den Fehlerbericht nur als letzten Ausweg benutzen. Zuerst informieren Sie sich bitte über neue Versionen, lesen die FAQ und besuchen Sie das Support-Forum.

Wenn all das nichts geholfen hat, schreiben Sie einen Fehlerbericht. Wenn Sie das erste Mal einen Fehlerbericht schreiben, müssen Sie evtl. die Maileinstellungen anpassen. Dies können Sie über den Knopf Mail-Einstellungen tun. Das Fenster, das sich daraufhin öffnet, lässt Sie alle nötigen Einstellungen vornehmen. Wenn Sie Outlook oder Outlook Express benutzen, können Sie diese Einstellungen (bis auf das Passwort) sogar übernehmen.

Sobald diese Einstellungen korrekt sind, drücken Sie den Knopf Weiter. In einer neuen Abteilung können Sie nun Ihren Bericht schreiben, den generierten Bericht einsehen und der Nachricht Dateien anhängen. Sobald Sie das getan haben, können Sie die Nachricht über den Knopf Absenden auf die Reise schicken.

Mehr Einstellungen zum Fehlerbericht finden Sie in der Abteilung Einstellungen.

Diese Abteilung ist erreichbar, indem Sie Fehlerbericht in der Abteilung Online auswählen.


Abo kündigen

Wenn Sie sich in der Vergangenheit aus Versehen bei einem Werbedienst eingetragen haben und nicht wissen, wo Sie sich wieder austragen können, haben Sie vielleicht Glück in der Anbieter ist hier gelistet. Dann können Sie sich auf der Webseite oder per Mail austragen (das Symbol vor dem Namen gibt an, worum es sich handelt).

Diese Abteilung ist erreichbar, indem Sie Abo kündigen in der Abteilung Online auswählen.


Sicherer Dateivernichter

Der sichere Dateivernichter entfernt Dateien endgültig, ohne dass diese wiederhergestellt werden können.

Das Vernichten ist einfach - ziehen Sie einfach ein paar Dateien aus einem Explorer-Fenster herüber (oder benutzen Sie das Kontext-Menü der Liste), stellen die Anzahl der Durchgänge ein, und klicken Sie den Knopf.

Gebrauchsspuren in Dateien werden übrigens standardmäßig mit 5 Durchgängen gelöscht.

Die ersten 5 Durchgänge werden mit vordefinierten Bitmustern gelöscht, die auch eine Hardwarewiedeherstellung unmöglich machen sollten. Für weitere Durchgänge werden zufällige Muster verwendet, die sich alle paar Bytes ändern.
Bitte beachten Sie: ein einzelner Durchgang ist nicht genug, um eine Datei endgültig zu vernichten, da die Festplattenköpfe nie 100,00% die Spur gleich treffen. Es gibt immer Ungenauigkeiten von ein paar µm, die Profis eine Wiederherstellung erlauben. Darum sind mehrere Durchgänge mit verschiedenen Bitmustern notwendig.

Warnung: Dieses Werkzeug vernichtet Dateien endgültig. Bitte beachten Sie, dass diese Dateien nicht wiederhergestellt werden können!

Disclaimer: Ich habe mein besten versucht, die Löschung sicher endgültig zu machen; garantieren kann ich natürlich nichts.

Dieses Werkzeug ist erreichbar, indem Sie Dateivernichter in der Abteilung Werkzeuge auswählen.


Beseitigung alter Spuren

Einige ältere Versionen von Spybot-S&D haben leider Einträge in der Registrierungsdatenbank erzeugt, die nur auf Existenz überprüft werden hätten sollen. Wenn Sie Spybot-S&D 0.9 to 0.94 benutzt haben, sollten Sie dieses Werkzeug verwenden.

Drücken Sie den Knopf Check for keys. Das kann eine Weile dauern und listet dann alle Einträge auf, die versehentlich erzeugt wurden. Diese können Sie mit dem Knopf Remove keys entfernen. Nur leere (d.h. unbenutzte) Schlüssel werden aufgelistet, so dass Sie keine Angst haben müssen, dass Schlüssel beseitigt werden, die damals noch nicht verhanden waren, inzwischen aber benutzt werden.

Es besteht keine Notwendigkeit, dieses Werkzeug öfter als einmal zu verwenden, wenn Sie keine älteren Spybot-S&D-Versionen weiter benutzen (was sie sowieso nicht tun sollten).

Dieses Werkzeug ist erreichbar, indem Sie Alte Spuren in der Abteilung Werkzeuge auswählen.